U
    9Š]Ý  ã                   @   sD   d dl mZ G dd„ deƒZeZeD ]Zeeej ¡ eeƒƒ q$dS )é    )ÚIntEnumc                   @   sr  e Zd ZdZdOeed dœdd„Zedœdd„Zeeed	œd
d„ƒZ	eee
d	œdd„ƒZeee
d	œdd„ƒZeee
d	œdd„ƒZdZdZdZdZdZdZdZdZdZdZdZdZdZdZd Zd!Zd"Zd#Zd$Z d%Z!d&Z"d'Z#d(Z$d)Z%d*Z&d+Z'd,Z(d-Z)d.Z*d/Z+d0Z,d1Z-d2Z.d3Z/d4Z0d5Z1d6Z2d7Z3d8Z4d9Z5d:Z6d;Z7d<Z8d=Z9d>Z:d?Z;d@Z<dAZ=dBZ>dCZ?dDZ@dEZAdFZBdGZCdHZDdIZEdJZFdKZGdLZHdMZIdNS )PÚ
StatusCodeaÛ  HTTP status codes and reason phrases
    Status codes from the following RFCs are all observed:
        * RFC 7231: Hypertext Transfer Protocol (HTTP/1.1), obsoletes 2616
        * RFC 6585: Additional HTTP Status Codes
        * RFC 3229: Delta encoding in HTTP
        * RFC 4918: HTTP Extensions for WebDAV, obsoletes 2518
        * RFC 5842: Binding Extensions to WebDAV
        * RFC 7238: Permanent Redirect
        * RFC 2295: Transparent Content Negotiation in HTTP
        * RFC 2774: An HTTP Extension Framework
        * RFC 7540: Hypertext Transfer Protocol Version 2 (HTTP/2)
        * RFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)
        * RFC 7725: An HTTP Status Code to Report Legal Obstacles
    Ú )ÚvalueÚphraseÚreturnc                 C   s   t  | |¡}||_||_|S ©N)ÚintÚ__new__Ú_value_r   )Úclsr   r   Úobj© r   úr/var/www/html/staging.mfahmagazine.net/magazine_api/magazine_env/lib/python3.8/site-packages/httpx/status_codes.pyr
      s    zStatusCode.__new__)r   c                 C   s
   t | jƒS r   )Ústrr   )Úselfr   r   r   Ú__str__   s    zStatusCode.__str__)r   r   c                 C   s(   zt |ƒjW S  tk
r"   Y dS X d S )Nr   )r   r   Ú
ValueError©r   r   r   r   r   Úget_reason_phrase   s    zStatusCode.get_reason_phrasec                 C   s   |t jt jt jt jt jfkS r   )r   ÚMOVED_PERMANENTLYÚFOUNDÚ	SEE_OTHERÚTEMPORARY_REDIRECTÚPERMANENT_REDIRECTr   r   r   r   Úis_redirect%   s    özStatusCode.is_redirectc                 C   s   d|  kodkS   S )Né�  ió  r   r   r   r   r   Úis_client_error4   s    zStatusCode.is_client_errorc                 C   s   d|  kodkS   S )Néô  iW  r   r   r   r   r   Úis_server_error8   s    zStatusCode.is_server_error)éd   ZContinue)ée   zSwitching Protocols)éf   Z
Processing)éÈ   ÚOK)éÉ   ZCreated)éÊ   ZAccepted)éË   zNon-Authoritative Information)éÌ   z
No Content)éÍ   zReset Content)éÎ   zPartial Content)éÏ   zMulti-Status)éÐ   zAlready Reported)éâ   zIM Used)i,  zMultiple Choices)i-  zMoved Permanently)i.  ZFound)i/  z	See Other)i0  zNot Modified)i1  z	Use Proxy)i3  zTemporary Redirect)i4  zPermanent Redirect)r   zBad Request)i‘  ZUnauthorized)i’  zPayment Required)i“  Z	Forbidden)i”  z	Not Found)i•  zMethod Not Allowed)i–  zNot Acceptable)i—  zProxy Authentication Required)i˜  zRequest Timeout)i™  ZConflict)iš  ZGone)i›  zLength Required)iœ  zPrecondition Failed)i�  zRequest Entity Too Large)iž  zRequest-URI Too Long)iŸ  zUnsupported Media Type)i   zRequested Range Not Satisfiable)i¡  zExpectation Failed)i¢  zI'm a teapot)i¥  zMisdirected Request)i¦  zUnprocessable Entity)i§  ZLocked)i¨  zFailed Dependency)iª  zUpgrade Required)i¬  zPrecondition Required)i­  zToo Many Requests)i¯  zRequest Header Fields Too Large)iÃ  zUnavailable For Legal Reasons)r   zInternal Server Error)iõ  zNot Implemented)iö  zBad Gateway)i÷  zService Unavailable)iø  zGateway Timeout)iù  zHTTP Version Not Supported)iú  zVariant Also Negotiates)iû  zInsufficient Storage)iü  zLoop Detected)iþ  zNot Extended)iÿ  zNetwork Authentication RequiredN)r   )JÚ__name__Ú
__module__Ú__qualname__Ú__doc__r	   r   r
   r   Úclassmethodr   Úboolr   r   r   ZCONTINUEZSWITCHING_PROTOCOLSZ
PROCESSINGr$   ZCREATEDZACCEPTEDZNON_AUTHORITATIVE_INFORMATIONZ
NO_CONTENTZRESET_CONTENTZPARTIAL_CONTENTZMULTI_STATUSZALREADY_REPORTEDZIM_USEDZMULTIPLE_CHOICESr   r   r   ZNOT_MODIFIEDZ	USE_PROXYr   r   ZBAD_REQUESTZUNAUTHORIZEDZPAYMENT_REQUIREDZ	FORBIDDENZ	NOT_FOUNDZMETHOD_NOT_ALLOWEDZNOT_ACCEPTABLEZPROXY_AUTHENTICATION_REQUIREDZREQUEST_TIMEOUTZCONFLICTZGONEZLENGTH_REQUIREDZPRECONDITION_FAILEDZREQUEST_ENTITY_TOO_LARGEZREQUEST_URI_TOO_LONGZUNSUPPORTED_MEDIA_TYPEZREQUESTED_RANGE_NOT_SATISFIABLEZEXPECTATION_FAILEDZIM_A_TEAPOTZMISDIRECTED_REQUESTZUNPROCESSABLE_ENTITYZLOCKEDZFAILED_DEPENDENCYZUPGRADE_REQUIREDZPRECONDITION_REQUIREDZTOO_MANY_REQUESTSZREQUEST_HEADER_FIELDS_TOO_LARGEZUNAVAILABLE_FOR_LEGAL_REASONSZINTERNAL_SERVER_ERRORZNOT_IMPLEMENTEDZBAD_GATEWAYZSERVICE_UNAVAILABLEZGATEWAY_TIMEOUTZHTTP_VERSION_NOT_SUPPORTEDZVARIANT_ALSO_NEGOTIATESZINSUFFICIENT_STORAGEZLOOP_DETECTEDZNOT_EXTENDEDZNETWORK_AUTHENTICATION_REQUIREDr   r   r   r   r      sŽ   r   N)	Úenumr   r   ÚcodesÚcodeÚsetattrÚ_name_Úlowerr	   r   r   r   r   Ú<module>   s   